rstudio ubuntuベースでRバージョンを簡単に切り替える方法は?

How to easily switch R versions on rstudio ubuntu based?


質問 written by Joni Hoppen @2019-01-14 14:55:40Z

: 0 : 1 : 60

次のエラーが発生するパッケージをインストールする必要があるため、その解決策を探しています。 最初のアプローチは、適切なRバージョンを選択する方法を検討することです。 ここに画像の説明を入力してください

これにもう少し時間をかける必要がありますか、またはこの問題を克服する他のアプローチがありますか?

コメント 1

Rバージョンを変更しても、上記のパッケージの古いバージョンは自動的にインストールされません。パッケージの特定のバージョンをインストールするには、そのURLが必要です。これをチェックしてくださいsupport.rstudio.com/hc/en-us/articles/…Rバージョンの変更は、パッケージバージョンとRバージョンに関するトラブルを避けるために役立ちます(私の経験では一般的ではありません)。

written by クリス @2019-01-14 14:58:25Z

回答 1 written by mischva11 @2019-06-07 13:54:25Z
2

このパッケージにはR(≥3.5.0)が必要なので、R 3.4.4は標準インストールには不十分です。

詳細については、パッケージのcran Webサイトで確認してください。

UbuntuでRをアップグレードするには、 こちら(古いリンク!)

編集:wibeasleyは、UbuntuでR 3.5.0を更新するためのコメントに新しいリンクを記載しました。 新しいリンクを確認してください

コメント 1

R≥3.5.0のその他のUbuntuインストール情報: askubuntu.com/questions/1031597/r-3-5-0-for-ubuntu上記の2番目のリンクが2012年に作成されてから、一部の設定が変更されました

written by 。– wibeasley @2019-01-15 16:58:59Z